Updated forum version, bug reports!

Issues with our forum or website.
User avatar
deen
Retired Administrator
Posts: 3268
Joined: Mon May 05, 2014 2:30 pm
Player profile: deen

Re: Updated forum version, bug reports!

Post by deen » Mon Jul 17, 2017 6:48 pm

Index wrote:
Mon Jul 17, 2017 6:18 pm
Had to make a workaround for that since the Advanced Polls extension we use doesn't support phpBB 3.2 yet.

Edit: Update to 3.2.1, hopefully not many new broken things.

fokkonaut
User
Posts: 853
Joined: Wed May 13, 2015 5:59 pm
Player profile: fokkonaut

Re: Updated forum version, bug reports!

Post by fokkonaut » Mon Jul 17, 2017 8:41 pm

pm email notification doesnt work for me

fokkonaut
User
Posts: 853
Joined: Wed May 13, 2015 5:59 pm
Player profile: fokkonaut

Re: Updated forum version, bug reports!

Post by fokkonaut » Tue Jul 18, 2017 1:26 am

maybe not that big bug, but if you are here and click on an forum then, the clicked one is Not underlined. as i said maybe not a (big) bug

Index
User
Posts: 1069
Joined: Mon May 05, 2014 7:30 pm
Player profile: ٭ıƞdex'<3
Mapper profile: ٭ıƞdex'<3
Clan: Eagle

Re: Updated forum version, bug reports!

Post by Index » Mon Jul 24, 2017 10:53 am

GG Kid just showed me another bug, and just saw that its somehow affecting quite a lot.
Named spoilers seem to be kinda broken since the update.

Code: Select all

[spoiler=ABC]ABC[/spoiler]
This will not display the title anymore, just a regular spoiler without anything.
And combined with that, it seems like certain bbcode doesn't work anymore inside spoilers. For example the Entites Guide is totally messed up for me: https://forum.ddnet.tw/viewtopic.php?f=16&t=2432

Maybe it has something to do with the outdated board expansions for extended editor menu, spoilers seem to be part of it :o
Oh, and it's not a " this time I guess xddd

User avatar
deen
Retired Administrator
Posts: 3268
Joined: Mon May 05, 2014 2:30 pm
Player profile: deen

Re: Updated forum version, bug reports!

Post by deen » Wed Jul 26, 2017 6:10 pm

I tried to fix it and encountered the following problems:

- Missing permissions for most bbcodes, added them
- Wrong ordering, of tags, don't do [align][spoiler][/align][/spoiler]. Maybe that used to work, but it shouldn't
- Got us a new spoiler extension
- Reran the phpbb parser over all posts, so they should be fine now. If you find more problems, tell me

jao
Testing Team: Team Leader
Posts: 1251
Joined: Wed Jul 06, 2016 1:18 pm

Re: Updated forum version, bug reports!

Post by jao » Wed Jul 26, 2017 6:24 pm

these don't work now: [release=][mod=][decline][highlightbox=]

User avatar
deen
Retired Administrator
Posts: 3268
Joined: Mon May 05, 2014 2:30 pm
Player profile: deen

Re: Updated forum version, bug reports!

Post by deen » Wed Jul 26, 2017 6:31 pm

Thanks, fixed. Anything else?

jao
Testing Team: Team Leader
Posts: 1251
Joined: Wed Jul 06, 2016 1:18 pm

Re: Updated forum version, bug reports!

Post by jao » Wed Jul 26, 2017 6:34 pm

Not sure if intended, but [mod=] looks really ugly now :D

User avatar
deen
Retired Administrator
Posts: 3268
Joined: Mon May 05, 2014 2:30 pm
Player profile: deen

Re: Updated forum version, bug reports!

Post by deen » Wed Jul 26, 2017 6:46 pm

Fixed too I think.

GG Kid
User
Posts: 252
Joined: Sun Apr 16, 2017 2:33 am
Location: U.S.A.
Player profile: Bolto
Clan: Kerger

Re: Updated forum version, bug reports!

Post by GG Kid » Mon Jan 29, 2018 8:12 pm

i have a post in search.php?search_id=newposts that is by "2aixe72ju" memberlist.php?mode=viewprofile&u=2053 that leads to viewtopic.php?f=3&t=6201 to an error
Screenshot.png
i'll assume it was spam and deleted but it's still a bug as i should see only non deleted posts.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest