Search found 33 matches

by ᴷᵉᵏᶳ
Fri Apr 13, 2018 7:30 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

well that sounds totally random to me, why would the client not let you set these settings? is your appdata read only?

Or do you mean your laptop doesn't go higher than vsync, bcs then its some GPU settings
by ᴷᵉᵏᶳ
Fri Apr 13, 2018 7:23 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

then use the console gfx_vsync 0
by ᴷᵉᵏᶳ
Fri Apr 13, 2018 7:14 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

well that's bad, if cl_refresh_rate is zero it should be at 100%, do you have vsync 1, and gfx_asyncrender_old 0?
by ᴷᵉᵏᶳ
Fri Apr 13, 2018 6:36 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

Unbenannt.PNG Did you look in this tab if one of your CPU cores is at full load? and does your taskmanager show the GPU usage? I still don't really believe it's the renderer from 10.8.6 to 11.0.3 the only thing i changed was removing a z value and changing the deepth calculation of the othographic ...
by ᴷᵉᵏᶳ
Fri Apr 13, 2018 1:03 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

Ok, then i would suggest doing a simple test. Set a small resolution and look if your FPS improove. If it gets much better with smaller resolutions, then it might indeed be some rendering. Else it's probably CPU related, and then i don't see any other chance then either try different compiler vs2017...
by ᴷᵉᵏᶳ
Fri Apr 13, 2018 9:20 am
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

Or we forgot some if(m_UseOpenGL3_3) somewhere in the code? Also, shouldn't it automatically downgrade if opengl3 fails? And that Windows GPU drivers don't support new OpenGL versions sucks... Well he complains about lags not crashes, if I get it right. It can automatically downgrade as long SDL do...
by ᴷᵉᵏᶳ
Thu Apr 12, 2018 11:58 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

https://ci.appveyor.com/project/heinric ... /artifacts

these are auto build releases from github, try the 64bit. Maybe the official release build is still unoptimized, dunno
by ᴷᵉᵏᶳ
Thu Apr 12, 2018 10:58 pm
Forum: Client Bugs
Topic: Client versions above 10.8.6 unusable
Replies: 42
Views: 3095

Re: Client versions above 10.8.6 unusable

Your GPU doesn't and won't ever support OpenGL 3.3, except your would swtich to linux and install MESA drivers https://de.wikipedia.org/wiki/Intel_HD_Graphics If you let it disabled it will render everything as in older clients. So it's probably a different problem for you. Backup your setting and r...
by ᴷᵉᵏᶳ
Thu Apr 12, 2018 4:28 pm
Forum: Client Bugs
Topic: High CPU load
Replies: 8
Views: 593

Re: High CPU load

On Windows I notice vsync delay, not on Linux btw. And are you sure Vsync actually works with your linux setup? it's not a secret that most linux drivers don't really implement vsync. Else you might have a modern driver doing exactly that, trying to not create any lag by waiting for the GPU to finish
by ᴷᵉᵏᶳ
Thu Apr 12, 2018 4:13 pm
Forum: Client Bugs
Topic: High CPU load
Replies: 8
Views: 593

Re: High CPU load

Yes, never enable VSync, it creates ugly lags, and anybody that plays on high level notices it.. it's the worst thing invented, and Nvidia and AMD try hard to replace it(Fast Sync, Enchanced Sync).

use gfx_refresh_rate if you want to limit your GPU usage.